Press "Enter" to skip to content

Setting up Cisco 877 with an external modem

Need to setup a 877 with an external ADSL modem in bridged mode? Maybe you have another modem which can sync/be more stable than the cisco and you wish to purely use the 877 as a router.

Following commands should help set it up..

Assign an ethernet interface to where it will use pppoe from, and assign it vlan2

interface FastEthernet3
description External DSL PPPoE
switchport access vlan 2

interface Vlan2
description External DSL PPPoE
no ip address
pppoe enable group global
pppoe-client dial-pool-number 2

setup a Dialer2 interface..

!
interface Dialer2
description connection to External DSL modem
ip address negotiated
ip access-group 101 in
no ip unreachables
ip nat outside
no ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1410
dialer pool 2
dialer idle-timeout 0
dialer-group 2
no cdp enable
ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password something

ip route 0.0.0.0 0.0.0.0 Dialer2

ip nat inside source list 102 interface Dialer2 overload

[ad#googleadd1]

5 Comments

  1. raskol
    raskol July 16, 2009

    Are you (in a round about way) saying that you are having issues with the c870-advsecurityk9-mz.124-24.T1.bin update and are therefore using an external modem now?

    I am having issues with our current c877 and was hoping the said update above would help…

  2. aLcAtRoN
    aLcAtRoN July 16, 2009

    I have encountered no problems with the 24.T1 IOS, this part works fine.

    I only have a small problem with the 877 ADSL chipset it uses, i dont know if its my distance from the exchange (4.9km) but it can proove a little unreliable. My SNR can jump around a lot and cause loss of sync quite a few times. The modem does not also sync at the highest speed possible compared to another modem im using. So now im using the 877 purely as a router, and letting another modem handle the sync speed. This other modem is a Billion 7300, and has a TREND chipset which syncs the highest on adsl lines, and its also quite stable. (more so than the 877s own). Although I think this could be all related due to the distance from exchange.

    What issues were you having with your current 877 setup?

  3. raskol
    raskol July 16, 2009

    Have been quite happy with the 877 for a good year on the 12.4(4)T8 release which came with it when purchased and then around two months ago got the disconcerting ‘clicking’ from the modem on a regular basis as it kept disconnecting. After updating the modem firmware to 3.0.010 this solved the problem for a good while…

    … BT (British Telecom, I am in London, UK) came over recently out of the blue and moaned about a problem on my line which they found difficult to fix. Finally after they had ‘fixed’ the problem (I had not noticed in the first place) our connection saps to around 15% every night and randomly at other times (only down speed though interestingly), causing me to reload the router to fix (or just pull the dsl line to reconnect). When it is working the speed is excellent, but then I am around 500m from the exchange.

    Anyway, it could be me, it could be them (the engineer who came round said there were ‘loads of new people milling around the exchange’ at the time) but have wanted to update it for a while and was interested in your experience with the latest release before I did.

    Great blog by the way, greatly appreciated here.

  4. aLcAtRoN
    aLcAtRoN July 16, 2009

    No worries, glad to help. I only started because the lack of info on cisco based gear and help/support 🙂

  5. rob
    rob March 20, 2013

    This is a helpful guide. I have recently had my line altered to include ADSL Annex M, which the Alcatel 20190 in the 877 cannot do (and will fall back to Annex A). So using PPPoE and a router in bridge mode, this has meant keeping the 877 and using an external modem to avoid a costly replacement.

    Just as an extra note, my ISP delivers IPv6 over my PPP session. The changes in IPv6 mean fragmentation doesn’t always happen where it used to happen on IPv4, and as such the MTU blows and the ethernet frame is silently dropped. This causes no end of unusual hangups with v6 connections. Nailing the MTU on the DialerN interface by using “mtu 1492” (not “ip mtu”, nor “ipv6 mtu”) fixes the problem firmly.

    Thanks for the original blog post. Really useful.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.