Press "Enter" to skip to content

Category: Cisco 877

Cisco 877W [Wireless Config]

Well i thought id post a Cisco877W wireless config, configured only as a access point. So..you can cut bits here and there and fit it into your existing 877 configuration. Bold indicates what you may need to change..

Cisco uses the Centre Frequency MHz to configure its wireless channel. So in our example below 2442 is used, which means that is actually Channel Identifier 7.

For more info on this you can see go here http://www.cisco.com/en/US/docs/routers/access/1800/wireless/configuration/guide/s37chan.html

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname yourhostname
!
boot-start-marker
boot-end-marker
!
enable secret yoursecretpass
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
bridge irb
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid YourAPssidhere
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii yourwirelesskeyhere
!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
channel 2442
station-role root
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.1.3 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip classless
!
no ip http server
no ip http secure-server
!
!
control-plane
!
bridge 1 route ip
!
!
line con 0
password yourconsolepass
login
no modem enable
transport preferred none
stopbits 1
line aux 0
line vty 0 4
session-timeout 240
access-class 2 in
password yourtelnetpass
login
transport preferred none
!
scheduler max-task-time 5000
end

[ad#googleadd1]

Leave a Comment

Cisco 877 Config [Internode] [PPPoA]

Here is a sample 877 config for ISP Internode in Australia which I use. It may work with other providers as well, the only items you need to modify is the hostname, password sections, timezone, and possible your IP addressing/subnets etc

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec show-timezone
service timestamps log uptime
service password-encryption
service internal
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 16000
logging console critical
enable secret yourpasswordhere
!
!setup timezone below default set to South Australia
no aaa new-model
clock timezone ACST 9 30
clock summer-time ACST recurring last Sun Oct 2:00 1 Sun Apr 3:00

!
!
dot11 syslog
no ip source-route
!
!
ip cef
no ip bootp server
ip name-server 192.231.203.132
ip name-server 192.231.203.3
!
!
!
!
!sets up a username of root with a password
username root privilege 15 password yourrouterpasswordhere
!
!
!
archive
log config
hidekeys
!
!
interface ATM0
description — Internode ADSL —
no ip address
no atm ilmi-keepalive
pvc 8/35
tx-ring-limit 3
encapsulation aal5snap
protocol ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
dsl bitswap both
!
interface FastEthernet0
no shut
!
interface FastEthernet1
no shut
!
interface FastEthernet2
no shut
!
interface FastEthernet3
no shut
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1420
hold-queue 100 out
!
interface Dialer1
description connection to ISP PPPoE 8/35 MUX
ip address negotiated
ip access-group 101 in
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly max-reassemblies 64
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp chap hostname [email protected]
ppp chap password (yourpassword)

!
interface Dialer0
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 102 interface Dialer1 overload
!
access-list 1 remark Permit our private network through the list
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 remark Just deny everything else
access-list 1 deny   any
access-list 101 deny   icmp any any echo
access-list 101 permit ip any any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!allow snmp below if required
snmp-server community public RO 1
!
!
!
!
control-plane
!
!
line con 0
password yourconsolepasshere
login
no modem enable
transport preferred none
stopbits 1
line aux 0
line vty 0 4
session-timeout 240
access-class 102 in
password yourtelnetpasswordhere
login
transport preferred none
!
scheduler max-task-time 5000
sntp server 129.127.40.3
end

1 Comment

Cisco IOS Feature Navigator

So you got your cisco device, but what if you want to quickly find the right IOS, and other software releases for features you want to run on your network. There are many different versions of the cisco IOS for each device. I came accross this handy cisco website which you can use to research software releases by searching by image name, platform, product code etc. Once you select what you want, it will give you more information about the particular IOS for your device, and what it can run.

So checkout:

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

I believe it will come in quite handy!

Leave a Comment